Breaking changes and migration guides

As described in the breaking change policy, on occasion we publish guides for migrating code across a breaking change.

To be notified about future breaking changes, join the groups Flutter announce and Dart announce.

When facing Dart errors after upgrading Flutter, consider using the dart fix command to automatically migrate your code. Not every breaking change is supported in this way, but many are.

To avoid being broken by future versions of Flutter, consider submitting your tests to our test registry.

The following guides are available. They are sorted by release, and listed in alphabetical order:

Not yet released to stable

Released in Flutter 3.19

Released in Flutter 3.16

Released in Flutter 3.13

Released in Flutter 3.10

Released in Flutter 3.7

Released in Flutter 3.3

Released in Flutter 3

Released in Flutter 2.10

Released in Flutter 2.5

Reverted change in 2.2

The following breaking change was reverted in release 2.2:

Network Policy on iOS and Android
Introduced in version: 2.0.0
Reverted in version: 2.2.0 (proposed)

Released in Flutter 2.2

Released in Flutter 2

Released in Flutter 1.22

Released in Flutter 1.20

Released in Flutter 1.17